Elite 800X - Not Detected by Audio Hub, 'Loading Device' Error

This article contains troubleshooting for the Elite 800X ONLY. Turtle Beach is not responsible for any issues caused by the misuse of the files in this article.

Note: Please keep the Elite 800X Headset connected to a USB port on your PC at all times. The Elite 800X can only be used with the Turtle Beach Audio Hub if both the headset and transmitter are connected to separate USB ports on your PC with their respective USB cables.


If you are having any issues updating the Elite 800X using the Turtle Beach Audio Hub or the software stops at "Loading Device", please try the following:

  • Close and reopen the Turtle Beach Audio Hub.
  • Use different USB ports.
  • Try a different computer (if available).

If you are unable to resolve the issue, close the Turtle Beach Audio Hub and install the appropriate WinUSB driver for your system (intended for the Elite 800X ONLY):

64-bit Windows Driver

32-bit Windows Driver

Note: click "Repair" if you are prompted to do so.

After installing the driver, disconnect and reconnect the transmitter, then reopen the Turtle Beach Audio Hub. The product should now load with the Turtle Beach Audio Hub.


 If you are still having difficulty with the Stealth 500X or Elite 800X and the Turtle Beach Audio Hub, please contact our Support Team: Contact Support


Was this article helpful?

If not, please drop us a comment below to let us know how this article can be improved.
Remember to use the phrase "KB Feedback".

0 out of 5 found this helpful
Return to top

Comments

0 comments

Please sign in to leave a comment.